End of support for Internet Explorer 10 and below

End of support for Internet Explorer 10 and below QuickBooks Help From the article: Why can’t I use QuickBooks in Internet Explorer 10 (IE10) or below? As you may know, in January 2016, Microsoft ended support for Internet Explorer 10 and below. This means that older versions of Internet Explorer will no longer receive critical […]